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Getting to Know the Desktop

So now you have Fedora installed on your 
machine and are ready and raring to go. 
The login screen that will appear every time 

you boot up Fedora Core is there waiting for 
you (see Figure 3-1 on the next page). 

There’s no need to keep the login screen waiting, so just type your username and 
press ENTER. After that, you will be prompted for your user password in the same 
screen. Type it in and press ENTER again. Now, within moments, you will have your 
first glimpse of your new desktop within Fedora. 
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Figure 3-1: The Fedora Core login screen

Welcome to the GNOME Desktop

As I mentioned earlier, your Fedora distribution comes with two graphical 
desktop environments: GNOME and KDE. Both have their own strengths and 
weaknesses, and, as such, both have their fans and detractors. However, as 
GNOME is the default environment in Fedora Core, and because I think it is 
much easier for new Linux users to deal with, we will focus on it almost 
exclusively in this book. 

In case you’re wondering whether or not you’re missing out on anything 
by using GNOME, let me assure you that you are not. You can run any KDE 
application from within GNOME, and vice versa. In fact, once you have a look at 
the Main menu, you will see that there are many KDE applications (apps, for 
short) listed in the various submenus. Most apps beginning with a K are KDE 
apps, such as the KAtomic and KBounce games, and the KPPP Internet dialer, 
which I will discuss in Chapter 4. If you followed my directions in Chapter 2, KDE 
is also installed on your machine, and you are free to use it on your own once 
you’re finished with this book. 

The GNOME desktop is shown in Figure 3-2, and as you can see, it isn’t all 
that different from what you might be used to in a Windows environment. But 
don’t be completely fooled; despite the similarities, things are different enough 
to be interesting. There are three main elements that you will probably notice 
right off the bat: the desktop icons, the GNOME Panel at the bottom of the 
screen, and the Main menu button at the far left corner of the GNOME Panel. 
I will focus on these elements in this chapter.
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Figure 3-2: The GNOME desktop

Desktop Icons

As you can see, there are three icons on the desktop: user’s Home, Start Here, and 
Trash. To makes things simple, we’ll start with the easiest and, no doubt, most 
familiar of these: Trash.

Trash

There is nothing mysterious about Trash . . . at least nothing mysterious about 
the desktop Trash icon. It functions just as it does in other operating systems. 
Drag a file you no longer need or want to the Trash icon, and the can will fill up. 
If you want to empty the Trash, just right-click the Trash icon and, from the pop-
up menu, select Empty Trash. If you drag something into the Trash that you are 
not supposed to, you will be informed that you can’t do that. All very simple and 
familiar, no matter from whence you came.

Start Here

Despite the name of this icon, you needn’t start with it. In fact, you can 
completely ignore it, as it is merely a collection of system preference links that 
can be more easily selected from the Main menu, but more on that later.
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user’s Home

The user’s Home icon on your own desktop will not say “user’s.” It will instead be 
labeled with whatever your username happens to be. For example, my username 
is “rg,” so my desktop icon says “rg’s Home.” If you are logged in as malachi, it 
will say “malachi’s Home,” and so on. All quite logical. Of course, I can’t possibly 
guess the username of every person reading this book, so I will stick to the more 
generic “user’s Home,” or just “Home,” when referring to this icon, and, as you 
will soon find out, I will do so very often.

As you will notice, the Home icon is the image of a house (home) on a 
folder. This should tell you that it is your home folder — something like the My 
Documents folder in a Windows system. This is where all your files will be saved 
to, all your downloads will be downloaded to, and all your music will be ripped 
to. It is your territory and, even if you are on a multi-user machine, nobody 
except you (assuming you are the only one who knows the root password) will 
be able to nose around in there.

Nautilus

If you double-click your user’s Home icon, a window will open up showing you 
the contents of the folder — it serves as a shortcut to your user’s folder on the 
hard disk. The program that creates this file-viewing and file-organizing system is 
called Nautilus. You may not have thought of an operating system’s file manager 
as a program before, but, in fact, that is what it is. 

Nautilus has a lot of interesting features that deserve mention. For example, 
Nautilus has a very cool feature that no doubt was inspired by Mac OS 9’s 
WindowShade feature: Double-clicking the title bar of any Nautilus window 
causes the window to roll up, so to speak, into the title bar — a useful feature 
when trying to get one window out of the way for a moment or two. There are 
many more such features, so I will point out a few now, and more will appear in 
later chapters.

Nautilus as an Image Viewer

One of the very handy things about Nautilus is that it acts as a sort of picture 
viewer and previewer. When you view the contents of a folder that contains 
graphics files, Nautilus displays thumbnails of the files (as shown in Figure 3-3) 
along with the filenames. This lets you see your graphics files without having to 
use any other special imaging software. Admittedly, this feature is no longer 
unique in the world of operating systems, but it is handy nonetheless.

lfng_book.book  Page 34  Tuesday, February 10, 2004  10:22 AM



A New Place to  Cal l Home 35

Figure 3-3: Viewing thumbnails in a Nautilus window

What is unique in Nautilus, however, is that when you double-click one of your 
thumbnails, the image will open in the same window at a larger size, as shown in 
Figure 3-4. In addition to that, you can zoom in to and out of the enlarged image 
by manipulating the + and – magnifying glass buttons or by right-clicking that 
general button area and selecting the desired percentage of zoom directly from 
the pop-up menu. 

Figure 3-4: Viewing an enlarged image in a Nautilus window
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You cannot manipulate the image in any way while viewing it in Nautilus, but if 
you want to make any changes to the image, all you have to do is right-click it and 
then select Open With > The Gimp in the pop-up menu, which opens the file in 
the GIMP — the Linux world’s answer to Photoshop (more about using the 
GIMP later in this chapter and in Chapter 14). With the GIMP, you can, among 
other things, change the size of the image, adjust the color balance, brightness, 
and contrast, convert the image from one format to another (from .jpg to .png, 
for example), airbrush in a beauty mark on your cheek, and even stamp little 
green peppers all over your head. All very cool indeed.

Using Nautilus to View Text and PDF Files

In addition to letting you view graphics files, Nautilus also allows you to read the 
contents of text files (those saved with a .txt file format), again without the need 
for any other software. If, for example, you have some notes that you jotted down 
and saved as a text file, you can simply double-click the file’s icon in Nautilus, 
and its contents will be displayed in the Nautilus window. Nautilus can even do 
the same for PDF files, acting as a simple PDF previewer.

The Nautilus Side Pane

Nautilus also has a side-pane feature that opens up a variety of options. To see 
the side pane, go to the View menu at the top of a Nautilus window and select 
Side Pane. Your Nautilus window will now show a mostly empty pane on its left 
side, with your username emblazoned upon it. In addition to your username, the 
side pane also shows how many files and subfolders you have in the folder you 
are currently viewing, and when you last added or deleted any files or subfolders 
in that folder. If that isn’t enough to get your blood flowing, there’s more.

Figure 3-5: Using the Tree view in the Nautilus side pane
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If you click the Information menu within the side pane, you can see other 
options. Perhaps the most useful of these, and one that a Windows user should 
feel quite at home with, is the tree option. If you select Tree from the 
Information menu, a folder tree of your entire hard-disk layout will appear 
within the pane (see Figure 3-5). You can click on any folder in the tree, and its 
contents will be displayed in the main portion of the Nautilus window. This is 
very handy when you are busily searching for something within the various 
subfolders you will eventually create.

Bookmarks Within Nautilus

Another very handy feature of Nautilus is that it lets you create bookmarks. You 
are no doubt familiar with creating bookmarks for Web pages that you frequent, 
but why on earth would you want to create bookmarks within your file system? 
Well, imagine that you have a folder that you need to use often, but it takes an 
excessive number of mouse clicks to get to that folder, and all that clicking is 
giving you a bad case of carpal tunnel syndrome. Instead of maiming yourself in 
that way, you could click your way to that folder once, and then, in the 
Bookmarks menu of the Nautilus window, select Add Bookmark. After that, 
whenever you want to get back to that well-buried folder, you can just click the 
Bookmarks menu, and that folder will be right there waiting for you in the drop-
down list (see Figure 3-6). 

Figure 3-6: Using the Nautilus Bookmarks menu

Changing File and Folder Permissions Within Nautilus

You will find, as you make your way along in the Linux world, that occasionally 
you come across a file or folder that has a red, slashed circle symbol on it, as you 
can see in Figure 3-7 on the next page. I refer to this as the verboten (meaning 
forbidden, in German) symbol. This symbol can appear within an oval (meaning 
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that you don’t have permission to read that file), or with a pencil in the middle of 
it (meaning that you do not have permission to alter that file). This is another 
way that Linux tries to protect you, though in the case of copied CD files, it may 
not be clear as to how it’s doing so.

Figure 3-7: Files and folders with the verboten symbol

If you want to alter a file or gain access to a folder that has the verboten symbol, it 
is possible to do so in the Nautilus window, provided that you are listed as the 
owner of that file or folder. To change file or folder permissions, just right-click 
the file or folder in question, and then select Properties from the pop-up menu. 
Once the Properties window opens, click the Permissions tab, and you will see 
who the owner of the file or folder is and what you are allowed or not allowed to 
do with it (see Figure 3-8).

Figure 3-8: Changing permissions in the Nautilus Properties window 
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You might find this permissions business a bit confusing, but it is really quite 
simple to understand. As you can see in Figure 3-8, permissions can be granted 
or denied to the owner of the file or folder (you), to a specified group, or to others 
(everybody else). These permissions are:

Read Permission to view the contents of a file or folder.

Write Permission to alter the contents of a file or folder.

Execute Permission to run a program or script.

In general, you needn’t worry all that much about setting permissions for your 
own files, as you are really the only one who has access to your user account. The 
main exception to this is when you transfer files from CD to your hard disk. In 
this case, the files will be write-protected, meaning that you cannot alter the files 
until you change the permissions for them. You will also eventually find, 
especially when you try to change system settings or install additional program 
packages, that there are a good number of files and folders that are protected by 
root permissions, but you will learn how to deal with that in Chapter 9.

If you are dealing with a folder or file that you have transferred from CD and 
that, thus, has the red verboten symbol with a pencil in it, you can change the 
permissions to allow you to alter that file by clicking the checkbox in the Owner 
row next to the word Write. Once you are done, click the Close button, and 
you’ll be on your way.

The Main Menu

At the very bottom left corner of your screen is an icon of a red hat. This is the 
Main menu, which is your access point to the majority of the applications and 
utilities included on your system. In a sense, the Main menu is very much like the 
Start menu in a Windows system, although it is not exactly the same. When you 
click the Main menu icon, all of the applications and utilities available to you are 
exposed.

Despite the importance of this menu, there is really very little to explain 
about it, although a complete explanation of each item in the menu wouldn’t fit 
in this book. My personal feeling is that it is fun to just browse through the 
various items in the menu in order to see what you have to work or play with. It’s 
sort of like digging down to the bottom of a Christmas stocking. I will also discuss 
some of these menu items in other chapters of this book, so if you’re not the 
treasure-hunting type, just hang in there. 

For the time being, however, I will give a brief explanation of the bottom 
eight items in the menu, because many of these are of considerable importance:

Help Starts a viewer for GNOME help files. 

Home Folder Opens your user’s Home folder.

Network Servers Allows you to view the other computers connected to 
your local network.
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Run Program Allows you to launch a program by typing the run command 
for that program. After selecting Run Program, a dialog box will open (see 
Figure 3-9). Type glines to give it a try (the application’s icon will almost 
immediately appear on the left), and then click Run. The game, Lines, will 
then start. Of course, we are too busy right now to be playing games, so just 
quit the program for now.

Figure 3-9: The Run Application dialog box 

Search for Files Helps you find files on your system. To give it a spin, select 
Search for Files. The search window will open. In the Look in folder field, 
your home folder will be the default search location. However, if you want 
to search the entire system and not just your home folder, delete everything 
in that box except the slash (/). Now, give it a try by trying to locate one of 
the icons we will be using in Project 3A-8. In the File is named field, type 
kolf.png, and then click Find. Your results should look like those in 
Figure 3-10.

Open Recent Shows a submenu of recently opened files.

Figure 3-10: Search results for kolf.png in the Search for Files window
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Lock Screen Activates your screensaver and locks the screen so that no one 
can use your computer without typing your user password first. This is very 
handy when you are going to be away from your computer for a few minutes 
and don’t want anyone messing around with things. You can give it a try 
right now if you like.

Log Out Opens a window asking you whether you want to log out, shut 
down, or restart — just like Windows XP. I’ll mention a bit more on this at 
the end of the chapter.

The GNOME Panel

As you have seen, the Main menu is located in the panel at the bottom of the 
screen. This panel is a separate application, or program, called the GNOME 
Panel (see Figure 3-11). In operation, it is sort of a cross between the Windows 
taskbar and the Mac OS X dock; and like both of those panel-like applications, it 
can be moved, hidden, resized, and customized to an even greater extent than 
with either of those two.

Figure 3-11: The GNOME Panel

When you first set eyes on the GNOME Panel, you will notice that it has a default 
set of icons on it. Some of these are program launchers, which allow you to start 
up a program with a single mouse click, while others are utilities of one sort or 
another. Here they are, from left to right:

Main menu The access point to the majority of your applications, 
preferences, settings, and other configuration tools.

Mozilla Your Web browser. Essentially, it’s Netscape with a difference 
or two.

Ximian Evolution The very popular Linux email program, scheduler, and 
task manager.

OpenOffice.org Writer A Microsoft Word–compatible word processor. 

OpenOffice.org Calc A Microsoft Excel–compatible spreadsheet 
application. 

OpenOffice.org Impress A Microsoft PowerPoint–compatible presentation 
application. 

GNOME Print Manager An application that provides access to your print 
queues, settings, and print jobs.

Workspace Switcher An application that allows you to switch between 
virtual desktops (I’ll talk about this more in Project 3A-4).

Window List A list of windows or applications you have open (very 
Windows-like). In Figure 3-11, there are no applications open, and thus 
no windows are shown in the list.

Volume Control A control that allows you to adjust the overall volume of 
your system (Red Hat 9 users will have to add this themselves).
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Red Hat Network Alert Notification Tool A launcher for Up2date, which is 
a tool that allows you to update your Fedora Core or Red Hat Linux system 
directly via the Red Hat Network. You will learn more about Up2date in 
Chapter 19 and about APT, a handy alternative to Up2date, in Chapter 10.

Clock The obligatory desktop clock and calendar.

The GNOME Panel is not a static thing. You can add launchers (program 
shortcuts or aliases), utilities, and even amusements to make it do almost 
anything you want it to, within limits, of course. In the various stages of this 
project, you will customize your Panel to make things more convenient for you as 
you make your way through the rest of this book. You are, of course, free to 
change any of the customizations I ask you to make, but I’d suggest holding off 
on that until you finish the rest of the book — if you change things now, my 
instructions may not match what you see on your screen. Once you’ve finished 
the book, you can do whatever you like.

Each of the following subprojects in this project is very simple. Most are only 
two-step point-and-click procedures that you should be able to handle without 
any difficulty. 

3A-1: Adding a Show Desktop Button to the Panel

One item not initially displayed in the GNOME Panel is the Show Desktop 
button. This is a handy utility that, when clicked, hides all the open windows so 
that you can see your previously obscured desktop. You may doubt whether you 
really need this, but trust me — you will eventually come to need and love this 
little button. 

To add the button, here is all you have to do:

1. Right-click the GNOME Panel in an empty space to the left of the 
Volume Controller.

2. In the pop-up menu, select Add to Panel > Actions > Show Desktop Button.

3A-2: Adding a Home Folder Launcher to the Panel

Even if I weren’t going to ask you to open your user’s Home folder a million 
times throughout this book, you would still find a launcher that opens up your 
Home folder in Nautilus to be of great convenience. Once you’ve added this 
launcher to your Panel, you will always be able to open up a Home folder 
window even if you have a slew of other windows open and cannot see any of 
your desktop. 

Project 3A: Customizing the GNOME Panel
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Here’s how to add the launcher:

1. Right-click any open space to the left of the Show Desktop icon toward the 
right end of the Panel.

2. From the pop-up menu, select Add to Panel > Launcher from menu > 
Home Folder.

3A-3: Deleting a Program Launcher from the Panel

Let’s say that you have a launcher on the Panel that you don’t particularly need. 
How can you get rid of it? As an example, let’s remove the launcher for 
OpenOffice.org Impress (don’t worry, you can always put it back later). 

Here’s what you do:

1. Right-click the OpenOffice.org Impress icon.

2. From the pop-up menu, select Remove from Panel.

3A-4: Adding a Program Launcher to the Panel

Now that you’ve created some extra Panel space to play with, let’s add a new 
program launcher. Because I will be asking you to use the Linux Command 
Terminal quite a bit in later chapters, that is the program you will add for now. 
To keep things tight and snappy, I’ll just refer to it as the Terminal from here 
forward.

Here’s what you do:

1. Right-click the open space to the right of the Workspace Switcher.

2. From the pop-up menu, select Add to Panel > Launcher from menu > System 
Tools > Terminal.

3A-5: Moving Icons on the Panel

You will notice that your new Terminal launcher seems stuck out there on its 
own, far from the other application launchers. This doesn’t seem like a logical 
arrangement, so why don’t you move it. 

Here’s how:

1. Right-click the Terminal launcher that you just added in the previous 
section.

2. From the pop-up menu, select Move. Your cursor should now look like a 
crosshair.

3. Drag the Terminal launcher to a point just left of the GNOME Print 
Manager icon. The other launchers should automatically make room for 
the move.
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3A-6: Reducing the Number of Desktops on the Workspace Switcher

One of the really cool features of Linux is that it allows you to work with virtual 
desktops. Instead of viewing just one desktop, as in most operating systems, you 
can view and work in up to 100 discrete desktops, and you can switch between 
them with the Workspace Switcher. As things are, your Workspace Switcher 
should show four squares, each representing one desktop. This makes the icon a 
bit wide, and it takes up a bit too much space on your Panel. Because you are 
most likely new to the idea of virtual desktops, I think that two should be enough 
to play with for now — at least until you find out a bit more about them later in 
the chapter. 

Here’s how to reduce the number of desktops shown on the Workspace 
Switcher:

1. Right-click the Workspace Switcher icon.

2. From the pop-up menu, select Preferences. 

3. On the right of the Preferences window, where it says Number of work-
spaces, select 2, and then click the Close button.

3A-7: Adding a Drawer to the Panel

One of the features that I quite like about the GNOME Panel is the drawer. The 
drawer is a little pop-up panel that acts as the perfect location to place launchers 
that you do not want to place in your GNOME Panel because of space consider-
ations and that do not appear in the Main menu and therefore must be run by 
command. Launchers of this sort are useful for quickly opening most of the 
programs that you compile from source code and also for several KDE programs. 
Of course, you can put anything you want there, including frequently used files. 

Adding a drawer to your Panel is very easy:

1. Right-click any open space to the left of the Home Folder launcher.

2. In the pop-up menu, select Add to Panel > Drawer. 

3A-8: Adding Program Launchers to the Drawer

The drawer you’ve just added is, of course, empty at this stage, so let’s put it to 
good use by adding launchers for a couple of KDE games that do not appear in 
the Main menu. One such game is KBattleship, which is a clone of the well-
known Battleship game. Another is a miniature golf game (and one of my 
personal faves), Kolf.

Here’s what you do:

1. A little tab with an arrow pointing downward should be visible above the 
drawer in your Panel. If the arrow isn’t visible, click once on the drawer, and 
it will be.

2. Right-click the tab and, from the pop-up menu, select Add to Panel > 
Launcher. A Create Launcher window will open (see Figure 3-12).
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Figure 3-12: Creating a launcher in a drawer 

3. For both the Name and Generic Name, type Kolf.

4. In the Comment field, type: A miniature golf game.

5. In the Command field, type: kolf (no capitals).

6. Click the big square button that says No Icon. The Browse Icons window will 
then open (see Figure 3-13).

Figure 3-13: Choosing an icon for an application

7. At the top of the icons window, you should see /usr/share/pixmaps. Delete 
that, and type in /usr/share/icons/crystalsvg/48x48/apps/kolf.png, and then 
press ENTER. The Kolf icon should now appear in the Create Launcher 
window. 

8. Finally, click OK, and the launcher will appear in the drawer.
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To add a launcher for Battleship, follow the same steps as above, but in the Name 
and Generic Name fields, type KBattleship; in the Description field, type A KDE 
Battleship clone; in the Command field, type kbattleship (no capitals); and type 
/usr/share/icons/kdeclassic/32x32/apps/kbattleship.png for the location of the 
game icon.

3A-9: Adding a Fish to Your Panel

Now we come to what might seem the most useless part of this project: adding a 
fish, named Wanda, to your Panel. At first glance, Wanda does little more than 
bat her tail around and spurt out a bubble or two. However, if you click on her, a 
window will pop up telling you what Linux kernel you are running, what time it 
is, how long you have been logged on, and how many users are currently using 
your machine, which could be useful. 

To get a glimpse of Wanda in action, limited though that action may be, 
follow these steps:

1. Right-click an empty space to the left of the drawer.

2. From the pop-up menu, select Add to Panel > Amusements > Fish.

3A-10: Adding a Force Quit Button to Your Panel

Finally, to round things out, let’s get back to the realm of the clearly useful and 
add a Force Quit button to the Panel. The Force Quit button is a very handy 
utility that lets you quickly and easily deal with non-responding windows. Yes, it 
does happen on occasion: A window suddenly refuses to do anything. Regardless 
of what you want it to do or what it is supposed to be doing, it just sits there as if it 
is on strike (maybe it is). With just one click of the Force Quit button, your 
cursor becomes a powerful surgical instrument that will kill the window you 
click on. You needn’t worry, however, because you can immediately run such 
apps again, though in some cases you will have to reboot first. 

You definitely don’t want to be without this button, so here’s how to add it to 
the Panel:

1. Right-click the empty Panel space to the left of Wanda.

2. From the pop-up menu, select Add to Panel > Actions > Force Quit.

You are now done with this rather simple project. You have more or less learned 
the basics of Panel customization and, in the process, created a very useful Panel 
configuration. If you did everything the way I told you to, your Panel should now 
look like the one in Figure 3-14.

Figure 3-14: Your newly customized GNOME Panel
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More Panel Fun

In addition to the basic customization you’ve just done in the previous project, 
you can do a lot more to change the look and feel of your Panel. Most of these 
options are available by right-clicking any open space in the panel and then 
selecting Properties, which will bring up the Panel Properties window (see 
Figure 3-15).

Figure 3-15: The GNOME Panel Properties window

From this window you can change the position of the Panel, alter its size, change 
its color, or make it (but not the launchers on it) invisible — very cool. You can 
also set the Panel so that it will automatically disappear when you are not using it, 
and have it reappear when you bring your mouse cursor into the area where the 
panel normally resides. Don’t feel afraid to play around and give things a try — 
that’s half the fun!

Mac Users Can Feel Right at Home

Another cool feature of the GNOME Panel program is that you can add 
additional panels to other parts of the screen. Former Macintosh users can create 
a fairly Mac-like desktop by right-clicking any open Panel space and selecting 
Add Panel, which will cause a new panel to appear at the top of the screen. As is, 
the new panel will be a bit too fat to look like a Mac menu bar, but you can 
reduce its size in the Panel Properties window (a size of 29 or 30 pixels should do 
the trick). 

To further Mac-ify things, you can right-click the panel to add a Menu Bar in 
the left corner (select Add to Panel > Add Menu Bar), a Window Menu to the far 
right corner (select Add to Panel > Utility > Window Menu), a Clock (select Add 
to Panel > Accessories > Clock), a pair of Eyes next to that (select Add to Panel > 
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Amusements > Eyes), and a Sticky Notes utility (select Add to Panel > Accessories 
> Sticky Notes) to the left of that. This will give you a sort of hybrid Mac OS 9/X 
menu bar. With a few more touches here and there, Mac emigrants can quite 
easily create a desktop environment that looks very much like that in Mac OS X 
(see Figure 3-16).

Figure 3-16: A Mac OS X–like desktop with panels at the top and right side of the screen

If you are curious how to get the Aqua-like window borders and controls shown 
in Figure 3-16, flip to Chapter 5.

Virtual Desktops

It is now time to discuss a rather unique and convenient feature of Linux: virtual 
desktops. And the best way to understand what this virtual-desktop business is all 
about is to just give it a try. 

In your GNOME Panel, click on Wanda, your Home folder, and Mozilla. You 
will then have three windows open in your present desktop, or workspace. Now 
look at the Workspace Switcher icon on your panel. The top half of the icon 
should be blue; this is your present workspace. Click the bottom half of the icon, 
the gray half, and all your open windows will suddenly disappear.

Actually, nothing has really disappeared — you are just viewing a new 
desktop. All your other windows are still open and running in the previous 
desktop. In this second desktop you can open something else: Go to the Main 
menu and select Games > AisleRiot. The AisleRiot solitaire card game will 
soon appear. 
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You now have windows open in two different desktops, and you can switch 
back and forth between them. To do so, just go to the Workplace Switcher in 
your Panel and click the top gray box, which will take you to your original 
desktop. Once you’ve done that, the bottom box will become gray, and you can 
then click that one to go back to your game desktop.

As you can imagine, this feature has some potential benefits for you, in 
addition to helping you avoid clutter. Just imagine that you are at work typing up 
some long document in OpenOffice.org Writer. Eventually, you get a bit tired 
and decide to goof off a bit by playing GNOME Mines for a while. To do this, 
you switch to another desktop where you open and play the game. A bit later, 
when you notice your boss making the rounds of the office, you simply switch 
back to the first desktop so that you look busy when he walks by and says, 
“Keeping yourself busy, Boaz?” 

Phew!

It wouldn’t be fair to end this chapter without telling you how to take part in 
what seems to be the average Linux user’s greatest passion: screenshots. I don’t 
know why Penguinistas are so obsessed with screenshots; perhaps it is the fact 
that they can customize their system so much, or perhaps it’s just that screenshots 
can be taken so easily from within Linux. Whatever the reason, chances are that 
any personal Linux Web page you come across will have at least a few screenshots 
of that user’s desktop. 

Now that you’ve joined the waddling masses, you can join in the fun too, and 
in the process, show your friends and colleagues images of cool apps you have 
found, show your mother by email where such-and-such a menu selection is (as I 
have often done), or just show off the cool customizations you’ve done to your 
system after you’ve completed Chapter 5.

3B-1: Full-Screen Screenshots

Taking screenshots from within GNOME is pretty easy, and there are a few ways 
to go about it. To take a shot of your whole desktop, just press the PRTSCN (Print 
Screen) or PRTSCN-SYSRQ keys on your keyboard. A Save Screenshot window 
(shown in Figure 3-17 on the next page) will then open and, by default, will 
ask you to save your screenshot to your Home folder. If you want to save the 
screenshot to another folder, simply choose a different folder before you click 
the Save button.

Instead of using the PRTSCN key on your keyboard, you can add a screenshot 
button to your Panel that will do the same thing, though I don’t see much 
advantage in doing that, unless you want the I’m-taking-a-picture feeling that a 
button provides. Anyway, to add the button, just right-click any empty space on 
the Panel and select Add to Panel > Button > Screenshot. Then, when you want to 
take a screenshot, all you have to do is click the button. Kachunk!

Project 3B: Screenshots
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Figure 3-17: Saving a screenshot 

3B-2: Taking Screenshots of a Single Window 

If you only want to take a screenshot of a single window, rather than of the entire 
screen, the process is almost as easy. First, make sure your mouse cursor is 
hovering within the boundaries of the window that you want to take the shot of, 
and then just hold down the ALT key with one finger and press the PRTSCN key 
with another. The Save Screenshot window will open.

3B-3: Taking Screenshots with the GIMP

These methods of taking screenshots are simple, fun, and easy, but they do have 
one limitation: They do not let you take screenshots while you have a menu 
open. If you want to take a screenshot of the desktop or any window with an 
open menu, you will need to use the GIMP. 

Fortunately, taking a screenshot with the GIMP is also a very, very simple 
procedure. First, start up the GIMP by going to the Main menu and selecting 
Graphics > The GIMP. Once the ol’ GIMPster is open, go to the File menu at the 
top of the main GIMP window (that’s the one with all the tools in it), and select 
Acquire > Screenshot. 

The Screen Shot window will open shortly (see Figure 3-18). Once it is open, 
select Whole Screen and adjust the numbers in the Seconds Delay field at the 
bottom of the window in order to give yourself enough time to get to the menu 
you want open by the time the screenshot is taken. 

When you’re ready, click OK, rush to open whatever menu it is you want to 
take a shot of, and voilà, it will be done. The screenshot will soon open right 
there within the GIMP, and you can do with it as you will.

lfng_book.book  Page 50  Tuesday, February 10, 2004  10:22 AM



A New Place to  Cal l Home 51

Figure 3-18: Taking a screenshot with the GIMP 

Shutting Down

Well, now that you know your desktop environment so well, you may feel like 
calling it a day and shutting down your machine. To do so, just go to the Main 
menu and select Log Out. A small window will appear with three choices to 
choose from: Log out (default), Shut down, and Restart the computer. Select Shut 
down and then click OK, and the shutdown process will begin. If, however, 
nothing seems to happen after clicking OK, press CTRL + ALT + BACKSPACE in 
unison, which will bring you to the login screen (Figure 3-1 on page 32). Once 
there, click Shutdown at the bottom of the screen. This will bring up a small 
window asking you if you are sure you want to shut down. Just click OK, and 
shutdown will commence.

During the shutdown process, your screen will go back to text mode and you 
will see a string of white text and green Oks on a black screen as the system shuts 
down its various components. When it is all done, the system will most likely 
power down your computer as well, in which case you are done. On a few 
machines, however, the system cannot power down your machine. You will know 
if this is so in your case because the flow of text on the screen will stop at the 
words Power down. If you see those words on the screen and nothing else 
happens for 15 seconds or so, then just power down the machine manually by 
pressing the power button. It is completely safe to do so at that point.
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