RESEARCHsummary.ca

presents

Mastering SAP BW Reporting

Expert Level
User Guide

b/w experts.com
presents

Mastering SAP BW Reporting

Expert Level
User Guide

SAP, the SAP logo, mySAP, SAP R/2, SAP R/3, SAP BW, mySAP.com, mySAP BI, are trademarks of SAP Aktiengesellschaft, Systems, Applications and Products in Data Processing, Neuottstrasse 16, 69190 Walldork, Germany.

Copyright © 2004 by ResearchSummary.ca
Written permission from www.researchsummary.ca is required for all other uses.
All rights reserved.
SAP CORPORATE CONSULTING

CUSTOM BW TRAINING!

Achieve the maximum ROI on your BW implementation investment.

A successful Data Warehouse is measured by how often and to what extent your business community is using BW for reporting.

1 Week Customized BW Reporting Course Onsite!

Available exclusively through Research Summary Consulting, this class is taught by an Expert Level BW Consultant onsite, at your location.

We provide a proven Business Explorer (BEx) reporting curriculum and customize this training based on your specific requirements. Save time and money by receiving training unique to your business on your own BW system.

This course offers your employees the knowledge they need to create interactive web-based portals plus highly customized workbooks with drilldown functionality.

**BRIEF SUMMARY OF REPORTING TOPICS:**

Efficient Query Design  
BEx Analyzer  
BEx Browser  
BEx Web Application Designer  
Query Designer  
Reporting Agent  
Report Scheduling  
Custom Template Creation  
Best Practices and Standards for Reporting  
Data Security Considerations  
Hands-on Exercises catered to your data  
Post-training Support  
...and Much More....

**ABOUT RESEARCH SUMMARY CONSULTING**

Research Summary Consulting has a long and successful track record of teaching Business Information Warehouse (BW) to Fortune 500 companies throughout North America. We employ highly experienced classroom instructors with a passion to transfer in-depth knowledge of BW to our clients.

For more information on this or any of our other Corporate Consulting Services please contact our Sales Team at esolutions@researchsummary.ca
BEx Training - Beginner Topics

Overview of Data Warehouses
Basic Data Structure in SAP BW
Introduction to the Business Explorer Tools
Browser vs. Analyzer
Logging into the System
BEx Browser Components
- Create/Rename/Delete Folders
- Move and Organize Workbooks
- Add Websites, R/3 Transactions and Application shortcuts

BEx Analyzer Features
- Tools available from BEx Toolbar
- Using Excel Functionality in parallel
- Roles vs. History vs. Favourites
- Screen layout

Browser vs. Analyzer
Relationship of Technical Queries to Workbook files
BW-specific terminology
- Glossary

Changing Queries - Local Views vs. Global Views
Selection Criteria
- Multiple Selections
- Selection Options
- Wildcards

Using Text Elements
- Data Relevance
- Variables and Filters

Modifying Workbooks with OLAP functionality
- Drilldown/across
- Results Rows
- Swap columns
- Single value filters
- Free Characteristics
- Key Figures
- Multiple value filters
- Characteristic display options
- Sorting
- Hierarchies
- Undo options
- Properties

Exceptions
- Defining and using Exceptions
- Exception Variable Creation

Conditions
- Defining and using Conditions
- Condition Operands
- Condition Variable Creation

Exceptions vs. Conditions

Saving Workbooks
- Best practices
- Detaching Reports
- Emailing Results

Practical Exercises & Review
BEx Training - Advanced Topics

Review of Beginner Course Topics
Query Designer Screen
Building Queries from Data Sources
Infocubes vs. Multicubes
Query Designer Settings
  - Report Titles
  - Sequence of Entry Variables
  - Display Options
  - Columnar Queries
  - Characteristic Restrictions
  - Characteristic Properties
  - Key Figure Properties
  - Where-used feature
Restricted Key Figures
  - Business Content
  - Cube level vs. Query Level
Calculated Key Figures
  - Cube level vs. Query Level
  - Operands and Math Functions
Structures
  - Creation and Re-use
Variables
  - Variable Types
  - Variable Processing
  - Characteristic Variables
  - Key Figure Variables
  - Text Variables
  - Variable Offsets
Advanced Workbook Formatting
  - Moving Filters
  - Moving Text Elements
  - Creating Templates
  - Colour formatting
  - Inserting Graphics
  - Inserting Charts
  - Removing Toolbars and Gridlines
  - Single Workbook -- Multiple Queries
  - Deleting Results
  - External Excel Functions
Reporting Agent
  - Event Creation
  - Batch Printing
  - Exception Reporting
  - Package Creation
  - Package Scheduling
  - Reporting Log
  - Exception Log
Web Reporting
  - Template Creation
  - Web Application Designer
  - Web Objects (charts, navigation, results set, etc.)
  - Additional Features
Practical Exercises & Review
BW Reporting User Guide
A 200+ page practical resource teaching you how to use SAP’s Business Warehouse

Available exclusively through Research Summary, our BW Reporting User Guide is an essential resource for anyone using Business Warehouse.

Our text summarizes the functionality available in BW with practical explanations, frequently asked questions and detailed how-to's.

SAMPLE OF TOPICS COVERED:

Overview of Data Warehousing  Overview of BW BEx Tools  OLAP Functionality
Logging into the System  Browser vs. Analyzer  Microsoft Excel Integration
BEx Browser Functionality  Report Scheduling  Report Roll-out Strategy
BEx Analyzer Features  Queries vs. Workbooks  Data Security Options
BW Terminology  Creating Query Definitions  Administrator Workbench
Modifying Queries  Variables and Filters  Web Objects
Global vs. Local Views  Selection Criteria  Exception Log
Web Application Designer  Using Hierarchies  Web Templates
Exception Reporting  Building Conditions  Scheduling Packages
Pre-calculating Web Templates  Saving Workbooks  Restricted Key Figures
Best Practices  Advanced Workbook Formatting  Graphs and Charts
Using the Query Designer  Query Designer Properties  Custom Templates
Characteristics and Structures  Key Figures and Structures  Practical Exercises
Creating Calculated Key Figures  Ad-hoc Web Application Designer  Variable Types

...And Much More

To Order your copy today please visit http://www.researchsummary.ca/bw/Bwguide.html

For volume discounts or corporate licenses contact us at esolutions@researchsummary.ca
Mastering SAP BW Reporting

I. Fundamentals of Reporting ..........01
II. Business Explorer Overview ..........09
III. BEx Query Designer ..........48
IV. Navigating Workbooks ..........81
V. Variable Types ..........109
VI. Conditions and Exceptions ..........125
VII. Reporting Agent ..........134
VIII. Web Reporting ..........144
IX. RRI ..........169
X. Formatted Workbooks ..........183
XI. Glossary and FAQ ..........201
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>I. Fundamentals of Reporting</td>
<td>01</td>
</tr>
<tr>
<td>II. Business Explorer Overview</td>
<td>09</td>
</tr>
<tr>
<td>III. BEx Query Designer</td>
<td>48</td>
</tr>
<tr>
<td>IV. Navigating Workbooks</td>
<td>81</td>
</tr>
<tr>
<td>V. Variable Types</td>
<td>109</td>
</tr>
<tr>
<td>VI. Conditions and Exceptions</td>
<td>125</td>
</tr>
<tr>
<td>VII. Reporting Agent</td>
<td>134</td>
</tr>
<tr>
<td>VIII. Web Reporting</td>
<td>144</td>
</tr>
<tr>
<td>IX. RRI</td>
<td>169</td>
</tr>
<tr>
<td>X. Formatted Workbooks</td>
<td>183</td>
</tr>
<tr>
<td>XI. Glossary and FAQ</td>
<td>201</td>
</tr>
</tbody>
</table>
Creating Workbook Templates

Standard templates can be assigned to workbooks upon execution. Color schemes, visible toolbars, gridlines, and graphics can be customized. A template is nothing more than an empty workbook with some formatting.

A template is saved as an Excel workbook and stored on the BW server. Each BW Workbook is then assigned a default template, or letterhead, which loads in advance of the query.

Using templates allows you to set a common look and feel to a series of reports and it’s easy to accomplish.
Templates

BW Reports
Create a Workbook Template

Practical Exercise:

1. Launch the BEx Analyzer.
2. Enable Macros if you receive a security warning.
3. Using the Excel toolbar open a NEW workbook.
4. Follow the Excel menu path and choose Insert → Picture → Clip Art…
5. From the available images double-click on one to choose it.
6. Use the handles to resize the picture so that it doesn’t go below Row 8.
7. Click on cell E2 and type “My BW Reports”. Make the font bold and size 20.
8. Follow the Excel menu path and choose Tools → Options → View. Remove the checkbox for Gridlines.
Create a Workbook Template

Your template should resemble the following:

My BW Reports
Create a Workbook Template

Continue to build on your template:


10. Using the Borders icon found in the Excel toolbar choose a thick bottom border.

One of the tricks when creating formatted workbooks in BW is to position the cursor in the appropriate active cell before saving. The location of the active cell dictates the upper left corner where the BW data will start to load from.

11. Click on cell A10 to make it active.

When you execute a BW query into this workbook the data will be displayed starting at cell A10 and work its way down the worksheet.

12. Using the BW BEx toolbar select the Save icon → Save as new workbook…

13. If required log in to the appropriate server. Give your workbook a Description.

14. Click Save.
Create a Workbook Template

Final Result:

Your template will act as a letterhead for reports that you execute. Data will start in cell A10 (as indicated by the active cell below) and run down and across the worksheet.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

My BW Reports
Setting a Default Template

Once a template is created and saved to the BW server you must define certain settings within the BEx Analyzer so that your formatted letterhead is loaded before any reports you may execute.

To do so:

1. Using the BW BEx toolbar select the Settings icon → Permanent workbook template…

2. A pop-up window will allow you to choose your workbook template. Navigate to the one you saved earlier and select it. Click Ok.

3. Next go back to the BW BEx toolbar and select the Settings icon → New workbook on embed → is based on permanent template.
Setting a Default Template

Now the system is all set. To test out how permanent templates work you will need to execute a Query.

Try the following:

1. Close any open workbooks within the BEx Analyzer.

2. Using the BW BEx toolbar select the Open icon → Queries.

3. A pop-up window will allow you to choose a query to execute. Navigate to any particular one and select it. Click Ok.

4. A new workbook will appear with your default template loaded. When the query finishes executing, the results will be displayed below the letterhead.
Using a Workbook Template

Query output:

![Workbook Template]

My BW Reports

<table>
<thead>
<tr>
<th>Truck Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Center</td>
</tr>
<tr>
<td>-------------</td>
</tr>
<tr>
<td>A100</td>
</tr>
<tr>
<td>B100</td>
</tr>
<tr>
<td>C100</td>
</tr>
<tr>
<td>D100</td>
</tr>
<tr>
<td>D150</td>
</tr>
<tr>
<td>E100</td>
</tr>
</tbody>
</table>
Sets of Reports

Creating custom templates and inserting a query allows you to dictate the look and feel of your reports to match current corporate standards or to create a new style going forward.

Another key feature of workbooks is the ability to embed more than one query onto a single worksheet. This is usually best for small queries with known dimensions.

Inserting multiple queries onto a single worksheet or placing individual queries on separate worksheets allows a family of reports to be contained within a single Excel file.
Sets of Reports

The process to insert an additional query is the same regardless of whether the intended destination is the same worksheet or a new one.

Try the following:

1. Follow the steps in the previous pages to embed a query onto the first worksheet in an open workbook.

2. To insert an additional query click on a worksheet and choose a cell location for this second query to start from. For the example choose a new worksheet and select cell A1.

3. Using the BW BEx toolbar select the Tools icon → Insert query…
Sets of Reports

4. A pop-up window will allow you to choose a query to execute. Navigate to any particular one and select it. Click **Ok**.

5. When the query result has been retrieved it will be embedded into a different worksheet.

Very quickly you can build a family of reports by repeating these 5 steps and adding additional worksheets to your workbook. To add more worksheet follow the Excel menu path and choose **Insert → Worksheet**.

This workbook can be saved to either the BW server or your desktop. Upon opening you can have all the queries execute and refresh to ensure new data is always loaded.
Auto Refreshing Data

To ensure that all queries in your workbook are refreshed with the most recent data a query property must be checked.

In a workbook with one or more queries do the following:

1. Position the active cell to be within the results area of a query.

2. Using the BW BEx toolbar select the OLAP functions for active cell icon → Properties...

3. On the Interaction tab make sure that “Refresh query when opening workbook” is checked.

4. Repeat steps 1-3 for any additional queries.
Auto Refreshing Data

The properties of a query allow you to auto refresh the data each time the workbook is opened:
Auto Refreshing Data

Auto refreshing data can benefit a user community by always ensuring that the most recent data is displayed in the results. One downside of using this feature is load time. A family of queries within a workbook may take a long time to completely refresh.

The alternative is to allow your users to refresh queries themselves. Here is another tip to use when manually refreshing queries within a workbook.

1. Position the active cell to be within the results area of a query.

2. Using the BW BEx toolbar select the Refresh icon. The report will be regenerated.

3. Repeat for any additional queries.
Auto Refreshing Data

TIP:

To manually refresh all queries found in a workbook position the active cell outside the results area of a query.

Using the BW BEx toolbar select the Refresh icon.

You will be prompted with a message saying “No query is selected. Do you want to refresh all the queries in the workbook?”. Choose Yes.

The next page illustrates where to place the active cell.
### Auto Refreshing Data

**TIP:** Position the active cell outside the results area of a query.

![My BW Reports](image)

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td><strong>Truck Sales</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td><strong>Key Figures</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td><strong>Controlling Area</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td><strong>Truck Type</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td><strong>Payment Type</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td><strong>Billing Indicator</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td><strong>Cost Center</strong></td>
<td><strong>Truck Type</strong></td>
<td><strong>Payment Type</strong></td>
<td><strong>Billing Indicator</strong></td>
<td><strong>Amount</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>A100</td>
<td>CAB001</td>
<td>USD</td>
<td>#</td>
<td>318304.24</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>B100</td>
<td>CAB001</td>
<td>EUR</td>
<td>#</td>
<td>49683.31</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>C100</td>
<td>CAB001</td>
<td>USD</td>
<td>#</td>
<td>0.00</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>D100</td>
<td>CAB001</td>
<td>USD</td>
<td>#</td>
<td>21938564.24</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>D150</td>
<td>CAB002</td>
<td>EUR</td>
<td>X</td>
<td>1123945.35</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>D200</td>
<td>CAB003</td>
<td>EUR</td>
<td>#</td>
<td>5783.00</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>