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iSeries Access on i5

I

n the Stone Age of computing, during which many of us began our careers,
most users accessed the system through “dumb terminals.” These hard-wired
behemoths provided reliable access to the system. However, they lacked the
ability to compete with the emerging array of desktop applications available on
PCs. After two decades, PCs have become the standard method for accessing the
i5 server. This chapter reviews the features of iSeries Access.

Where Do I Get iSeries Access?
iSeries Access and related software components are delivered as part of licensed
program product 5722-XW1. To verify that you have this licensed program
installed, use the command GO LICPGM, and take option 10 to Display installed
licensed programs. If you cannot find the “Client Access Family for Windows”
listed there, you should have received a copy of the licensed program product on
CD with your i5 server. Once installed, you have 70 days of use before a software license key is required to continue using the product. See Chapter 12 for
instructions on installing iSeries Access on the PC client.
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iSeries Access Basics
The primary function of iSeries Access is to provide an interactive connection to
the i5 server. Figure 12.1 shows a standard sign-on screen. Across the top of the
screen are pull-down menus and action icons that provide access to a number of
useful features.

Figure 12.1: Sign-on screen.

Simply enter your user ID and password to log into the system, or use the pulldown menus or action icons shown in Figure 12.2 to access other features of
iSeries Access, which are listed below:

Figure 12.2: Pull-down menus and action icons.

■
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Print Screen. Use this icon
or find the option from within the File
pull-down menu to print a snapshot of the current screen.

Configuring iSeries Access

■

■

■

■

■

■

■

■

Run the Same. Use this option from within the File pull-down menu to run
a new copy of the iSeries Access application in a new window on your PC.
It will use the same configuration file that your current session does. If
your current session has an assigned device name, the new session will not
be able to connect until its configuration has been updated.
Run Other. Use this option from within the File pull-down menu to open
a new copy of the iSeries Access application in a new window on your
PC. It prompts you to provide a new configuration file.
Copy. Use this icon
or find the option from within the File pull-down
menu to copy a snapshot of the current screen to the clipboard.
Copy Append. Find the option from within the File pull-down menu to
copy a snapshot of the current screen to the clipboard, adding it to the
current contents.
Paste. Use this icon
or find the option from within the File pull-down
menu to paste the contents of the clipboard onto the screen at the place
where the cursor is located.
Connect. Find the option from within the Communications pull-down
menu to connect to the configured i5 Server.
Disconnect. Find the option from within the Communications pull-down
menu to disconnect from the configured i5 Server.
AutoConnect. Find the option from within the Communications pull-down
menu. It is set on by default, and causes iSeries Access to immediately
connect to the configured i5 Server.

Configuring iSeries Access
Several features of iSeries Access configure the behavior of the current session.
These include defining the current printer, configuring the session name and display
size, and a variety of other display features:
■

Printer Setup. Find the option from within the File pull-down menu to con
figure the default printer for this session. Figure 12.6 shows the Printer setup
wizard.
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Figure 12.6: Printer Setup wizard.

Select Use Windows Default Printer to set your Windows default printer as the
iSeries Access default printer. Click Setup to configure the properties of the selected
printer.
■

Configure. Find the option from within the Communications pull-down
menu to disconnect from the configured i5 Server.

Figure 12.7: Configure iSeries session.
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Select Use Computer Name to use the PC’s computer name as the device name for
this session. Select Use Windows User Name to assign the name of the logged-in
Windows user as the device name for this session. The most common choice is
Specify Workstation ID. If this option is selected, the device name is taken from
the text box (currently loaded with KPFATHOME). If that box is empty, a virtual
device name, such as QPADEV0001, is assigned.
To avoid duplicates device names, either with other application windows on this PC,
or with other PCs, iSeries Access provides three options, as shown in Figure 12.8.

Figure 12.8: Prefix and suffix options.

If you are using both display and printer sessions, you may wish to select the first
option shown in Figure 12.8, attaching a “P” or “D” as a prefix to the device name
to indicate which type of session it is.
If this session has an assigned device name, you may wish to select the option to
avoid duplicates names on this workstation. This allows you to create copies of
this session and establish multiple connections to the same server, each with a
unique device name. Therefore, if your assigned device name was “TEST,” the
first session would be “TESTA” and the second would be “TESTB,” and so
forth. If you are concerned about conflicts with duplicate device names being
used on other PCs, you may wish to select the option to avoid duplicates names
with other workstations. This adds a numeric suffix to the end of the device
name. Therefore, if your assigned device name was “TEST,” the first session
would be “TEST1” and the second would be “TEST2,” and so on.
If you used both options to avoid duplicates, the first device name is “TESTA1,”
and the second is “TESTB1.” However, if “TESTA1” is already in use on the
server, this session will alter its device name to “TESTA2,” and so on.
The Size setting can be either 24×80 or 27×132. For many, the smaller font used
by the 27×132 screen size is uncomfortably small and creates unwanted eye strain.
However, many people find that its ability to display more data on the screen at
once outweighs the problem.
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If you wish to simplify the login process you can select Bypass Signon. This
causes the system to log you into the server using the same user ID and password
you provided to connect to the server. Otherwise, a separate sign-on is required
after connecting to the server.
■

Preferences. Configure preferences from within the Edit pull-down menu.
Some of the more common preferences include:
z
z
z
z

Appearance
Hot spots
Keyboard Setup
Pop-up Keypad

Appearance
Appearance has severals subtopics, including Color Mapping, as shown in Figure
12.9. This option allows you to remap the standard display station colors to whatever
colors you prefer. The left-hand pane lists every type of display data, so that you can
configure the color attributes of each part of the display. Both the foreground and
background colors can be set, and a sample is displayed.

Figure 12.9: Color mapping.

The second option beneath Appearance is Display Setup, shown in Figure 12.10.
Within this option, you may configure the cursor shape and behavior, sound
effects, and the style of column separator and rule lines.
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Figure 12.10: Display Setup.

The third option beneath Appearance is Window Setup, shown in Figure 12.11.
This option configures the title and scroll bars. However, the single most important option here is the Status Bar. Select 5250 Message line to display i5 error
messages on the status bar of your window rather than on line 25 of the display.
Many users fail to see error messages placed on line 25. For most users, I suggest
deselecting that option.

Figure 12.11: Display setup.
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Hot Spots
Hot spots are clickable points on the display that mimic pressing a key on the
keyboard. Figure 12.12 displays a typical set of function options that you might
see on an i5 screen. Normally, you press a function key such as the F12 key to
exit. Using Hot Spots, you can double-click the constant F12 instead of pressing
the F12 button.

Figure 12.12: Display setup.

Only the Fxx text itself is a hot spot; the other associated text such as “=Exit” is not
part of the hot spot. If you prefer a more dramatic and obvious presentation of the
hot spots, use the preference tool shown in Figure 12.13 to configure the hot spots
to display as 3D buttons, as shown in Figure 12.14.

Figure 12.13: Display Setup.

Figure 12.14: 3D display setup.
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Keyboard Setup
Everyuser is different; each may have her own unique preferences for how her
keyboard should work. Rather than forcing all users to conform to one standard
keyboard configuration, iSeries Access allows each user to customize the behavior
of their keyboard. Select the Keyboard… option beneath Preferences on the Edit
pull-down menu to display the configuration screen shown in Figure 12.15.

Figure 12.15: Keyboard Setup.

If you have previously created a keyboard mapping file, you can use the Browse
button to select that file. To create or modify the configuration of the keyboard
mapping file, click Customize to display the panel shown Figure 12.16.

Figure 12.16: Customize keyboard.
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To change the behavior of a key, click the key in the image of the keyboard at
the top of the screen. Then, choose the new key, macro, or function that you
wish to assign to the key, using the options presented in the lower left side of the
panel. Once you have selected the new key, macro, or function, click the associated shift state in the lower right section of the panel. (Macros are discussed
later in this chapter.)
Functions are keys that cause some sort of action, rather than placing a
character on the screen. A few of the more common functions are:
■
■
■
■
■

Attention
Backspace
Enter
Field Exit
Help

Once all the changes are completed, select Exit from the File pull-down menu.
The system will prompt you to save the keyboard mapping file if necessary. To
share one keyboard mapping file among many users, save it to a network folder.

Pop-up Keypad
Many characters, macros, and functions do not
have obvious connections to specific keys. These
can be provided to the user through a Pop-up
Keypad such as the one shown in Figure 12.17.
Display the Pop-up Keypad by right-clicking the
mouse anywhere in the iSeries Access display.
Figure 12.17: Pop-up keypad.
To customize the Pop-up Keypad, select “Pop-up
Keypad…” under the Edit-Preference pull-down
menu. The Setup panel shown in Figure 12.18 is displayed. Select User defined,
then click Customize to display the user panel shown in Figure 12.19. Use this
panel to set the number, size, and color of the Pop-up Keypad as well as the
function keys and macros assigned to the keypad.
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Figure 12.18: Pop-up Keypad Setup.

Figure 12.19: Pop-up keypad customization.
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iSeries Access File Transfer
In addition to the 5250 terminal emulation provided, iSeries Access also
provides a simple file upload and download capability. The
upload and download icons shown in Figure 12.20 launch the file
transfer wizards. To download a file from the i5 server, select the
Figure 12.20:
download icon, which launches the wizard shown in Figure
Upload/Down12.21.
load icons.

Figure 12.21: Transfer data from i5 server.

Select the i5 server to download from, the file to download, and the file name to
save it under on your PC. To determine the format of the downloaded file, use
the Details option. If you are not sure which format to use, comma delimited is a
commonly used format and works well with applications such as Excel. The
transfer request can be saved for reuse, thus avoiding the need to re-enter the
same download options every time.
To upload a file to the i5 server, select the upload icon, which launches the
wizard shown in Figure 12.22.
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Figure 12.22: Transfer data to i5 server.

Select the file on the PC to upload, the i5 server to upload to, and the file name to
save it as on the i5 server. The wizard provides options to upload the file as
either source or data. The data may be placed into a new file, a new member, or
it may replace an existing member. The transfer request can be saved for reuse,
thus avoiding the need to re-enter the same download options every time.
Additional file upload and download options included with iSeries Access provide
plug-ins for use with Microsoft Excel.

iSeries Asccess Macros
Macros provide a tool for extending the functionality of
iSeries Access. These prewritten scripts can be simple or
complex. Assign macros to a key through keyboard mapping or
add them to the pop-up keypad. To create a Macro click the
Start keystroke recording icon shown in Figure 12.23, which
displays the wizard shown in Figure 12.24.

Figure 12.23:
Start and stop
keystroke
recording icon.

203

CHAPTER 12: iSeries Access on i5

Figure 12.24: Record keystrokes.

Enter the name of the macro file to save the keystrokes under.
Select the format of the file, either VB or Macro, and then
click OK. Whatever keystrokes are typed are recorded into
the macro file. Once all the desired keystrokes are entered,
click the Stop Keystroke Recording icon. To start or play an
icon, use the macros shown in Figure 12.25.

Figure 12.25: Start
Macro/Script icon.

For more information on Macros, check the help text or the IBM information
center at http://publib.boulder.ibm.com/html/as400/infocenter.html.

Summary
iSeries Access is a standard in the industry for providing connectivity to i5
servers. This chapter reviewed the basic components of iSeries Access. Many
users never take advantage of more than the basic 5250 emulation provided by
iSeries Access. But for users who wish to explore the more sophisticated features, iSeries access provides a number of powerful features for customizing
your interfaces to the iSeries and interacting with the i5 server.
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